Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 22, 2026 - 20:15 CDT
Scheduled
We have opened a broad maintenance window to perform routine maintenance on physical host systems in our US - East and US - Central regions.
This maintenance includes applying kernel updates, security updates, and other host-level maintenance required to keep our infrastructure current and secure.
No action is required on your part.
During this maintenance, VPS servers may experience a brief interruption of a few minutes while their physical host is rebooted and services are restored. While the maintenance window spans a longer period to accommodate multiple hosts, your individual VPS will only be affected during the reboot of its assigned physical host.
No changes will be made to your VPS configuration, operating system, applications, or data as part of this maintenance.
If you have any questions or experience any unexpected issues following the maintenance, please open a support ticket through your Gen5 Dashboard, and our Technical Team will be happy to assist.
Posted Sep 22, 2026 - 20:01 CDT
This scheduled maintenance affected: Gen5 VPS Infrastructure - North America (US - Central, US - East).