US - Central - (Minneapolis) - Incoming Network Latency
Incident Report for Arcustech, LLC
Resolved
This incident has been resolved.
Posted Jun 24, 2020 - 15:42 CDT
Investigating
Our team is investigating some possible network latency/speed issues in our Minneapolis, MN data center. We are not seeing it from all of our remote test locations, so are trying to pin down which upstream provider or further up past them it maybe coming from.

We will update date this when we have more info, or when we are not seeing any reports from our remote monitoring.
Posted Jun 24, 2020 - 15:05 CDT
This incident affected: VPS Infrastructure - US Central.