US - Central - (Minneapolis) - Upstream Routing Issues
Incident Report for Arcustech, LLC
Resolved
The issue is resolved, but as always staff will be monitoring our networks closely.
Posted Sep 07, 2020 - 21:58 CDT
Identified
Staff are working with our data center provider to route round upstream Level3 issues, again. Does not seem to be as full scale as their issues a week ago, but we are monitoring the situation.
Posted Sep 07, 2020 - 21:43 CDT
This incident affected: Account Portal, Customer Support Systems, and VPS Infrastructure - US Central.