US - Central - (Minneapolis) - Upstream Routing Issues
Incident Report for Arcustech, LLC
Resolved
Traffic levels and performance to client sites should be back to normal. We will continue to monitor this with our data center provider.
Posted Mar 01, 2021 - 21:48 CST
Identified
Looks like there are issues with the Level3/Lumen uplink outside of our data center providers network. They are working to remove the link from BGP mappings and route around the Level3/Lumen issues for now.
Posted Mar 01, 2021 - 21:34 CST
Investigating
Staff are investigating some upgrade routing issues outside of our network. We will update this incident as soon as we know more.
Posted Mar 01, 2021 - 21:32 CST
This incident affected: VPS Infrastructure - US Central.