US - Central - (Minneapolis) - Upstream Routing Issues
Incident Report for Arcustech, LLC
Resolved
Looks like the issue was on the Level3/Centurylink/Lumen uplink out of our MSP data center providers network. The issues has been cleared up, but being monitored.

As always if you are still having any problems please contact our support team help@arcustech.com
Posted Jan 10, 2021 - 03:35 CST
Investigating
Staff are investigating upstream routing issues in this data center location. We will update as soon as we have further details.
Posted Jan 10, 2021 - 03:20 CST
This incident affected: Account Portal and VPS Infrastructure - US Central.